An introduction to LISREL 8.80 for Windows

1. Introduction

LISREL 8.80 for Windows (Joreskog & Sorbom 2006) is a Windows software product for
structural equation modeling, multilevel structural equation modeling, generalized linear
modeling, multilevel linear modeling, multilevel generalized linear modeling, multilevel
nonlinear modeling, and formal inference-based recursive modeling. This product consists
of a 32-bit Windows Graphical User Interface (GUI) application LISWIN that interfaces with
the 32-bit statistical applications LISREL, PRELIS, MULTILEV, SURVEYGLIM, MAPGLIM,
CATFIRM, and CONFIRM.

PRELIS is a 32-bit application for manipulating data, transforming data, generating data,
computing moment matrices, computing asymptotic covariance matrices, performing
multiple linear, censored, logistic, and probit regression analyses, performing exploratory
factor analyses for continuous and ordinal variables, etc.

The 32-bit application LISREL is intended for standard and multilevel structural equation
modeling. The Full Information Maximum Likelihood (FIML) method for incomplete data is
also available for both standard and multilevel structural equation modeling. In the case of
continuous variables, standard structural equation modeling is also available for complex
survey data.

MULTILEYV fits multilevel linear and nonlinear models to raw data. In the case of continuous
response variables, MULTILEV allows for design weights at each level of the hierarchy.

SURVEYGLIM fits generalized linear models to simple random sample and complex survey
data.

MAPGLIM fits generalized linear models to multilevel data.

CATFIRM and CONFIRM implement formal inference-based recursive modeling for raw
categorical and continuous data respectively.

LISREL 8.80 for Windows imports external data in formats such as SPSS, SAS, STATA,
Statistica, Microsoft Excel, SYSTAT, BMDP, etc. as a PRELIS System File (PSF).

This document is intended as a brief overview to familiarize new users of LISREL 8.80 for
Windows with the features of the application. Section 2 describes the various files used and
generated by LISREL 8.80 for Windows. A procedure to import an SPSS data file as a PSF
to be used by LISREL 8.80 for Windows is described in Section 3. Some of the descriptive
graphics of LISREL 8.80 for Windows are illustrated in Section 4. A data screening, a
multiple linear regression analysis, and a logistic regression analysis with LISREL 8.80 for
Windows are illustrated in Sections 5, 6, and 7 respectively. Section 8 demonstrates an
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exploratory factor analysis for continuous and ordinal variables with LISREL 8.80 for
Windows. Section 9 illustrates how LISREL 8.80 for Windows can be used to run SIMPLIS
syntax files. Section 10 demonstrates some of the features of the path diagram (PTH)
window of LISREL 8.80 for Windows. The use of LISREL syntax files is illustrated in
Section 11.

2. Files

LISREL 8.80 for Windows uses a PRELIS System File (PSF) to store raw data. The
statistical applications LISREL, PRELIS, MULTILEV, SURVEYGLIM, and MAPGLIM read
the raw data values directly from a PSF.

Whenever PRELIS or LISREL processes a PSF, a Data System File (DSF), which has the
same file name as the PSF, but with a DSF extension, is created. This DSF contains all the
summary data information that LISREL requires to fit standard structural equation models
to complete data.

A structural equation model can be specified by means of a path diagram, a SIMPLIS
project file, a LISREL project file, a SIMPLIS syntax file, or a LISREL syntax file. LISREL
8.80 for Windows uses a graphics file with the default extension PTH to capture a path
diagram. The extensions SPJ and LPJ are used for SIMPLIS and LISREL project files
respectively. SIMPLIS and LISREL syntax files are text files with the default extensions
SPL and LS8 respectively. These five file types access the raw data from the PSF or the
summary data from the DSF. If a user has prepared any of these files, then LISWIN and
LISREL can be used to fit the specified model to the raw data specified in the
corresponding PSF or the summary data in the corresponding DSF.

Path diagram, SIMPLIS project and LISREL project files are described in Du Toit & Du Toit
(2001). SIMPLIS syntax files are described in Joreskog & Soérbom (1999c) while LISREL
syntax files are outlined in Joreskog & Sorbom (1999b). All these files are also described in
the online help file, which can be accessed by using the LISREL Help option on the Help
menu of LISREL 8.80 for Windows. In addition, SIMPLIS syntax files are also described in
http://www.ssicentral.com/lisrel/techdocs/SIMPLISSyntax.pdf

while LISREL syntax files are described in

http://www.ssicentral.com/lisrel/techdocs/LISREL Syntax.pdf#pagemode=bookmarks

Whenever PRELIS processes a PSF interactively, a PRELIS syntax file with the same file
name as the PSF is created. A PRELIS syntax file is a text file with default extension PR2.
PRELIS syntax files are described by Joreskog & Sérbom (1999a) as well as in the online
help file of LISREL 8.80 for Windows and in
http://www.ssicentral.com/lisrel/techdocs/IPUG.pdf

Multilevel modeling, generalized linear modeling, multilevel generalized linear modeling,
and formal inference-based recursive modeling syntax files are also text files with default
extension PR2. Multilevel modeling and generalized linear modeling syntax files are
described in Du Toit et al. (2005) while formal inference-based recursive modeling syntax
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files are described in Du Toit & Du Toit (2001). These types of syntax files are also
described in the online help file of LISREL 8.80 for Windows. MULTILEV and
SURVEYGLIM syntax files are also described in
http://www.ssicentral.com/lisrel/techdocs/MLUG.pdf

and

http://www.ssicentral.com/lisrel/techdocs/SGUG.pdf#pagemode=bookmarks

respectively.

LISREL 8.80 for Windows starts up by opening a main window with three menus entitled
File, View, and Help. The Open option on the File menu is used to open an existing PSF
or PTH file in a PSF and a PTH window respectively. It can also be used to open existing
LISREL and SIMPLIS project files in LISREL and SIMPLIS project (LPJ and SPJ) windows.
Text editor windows are used to display existing syntax files and output files. PTH, PSF,
LPJ, SPJ and text editor windows have window-specific menus.

The LISREL Help option on the Help menu opens the online help file of LISREL 8.80 for
Windows. The About LISREL option loads the About LISREL dialog box which shows the
product information for LISREL 8.80 for Windows.

3. Importing data as a PRELIS System File (PSF)

The PRELIS System File (PSF) is a binary file that LISREL 8.80 for Windows uses to store,
display and analyze raw data. LISREL 8.80 for Windows opens a PSF in a PSF window
with menus entitled File, Edit, Data, Transformation, Statistics, Graphs, Multilevel,
SurveyGLIM, View, Window, and Help. In this section, we will import an SPSS data file as
a PSF. Then, we demonstrate how to set up the PSF for further processing with LISREL
8.80 for Windows.

The Data

The data set forms part of the data library of the Multilevel Project at the University of
London, and emanates from the Junior School Project (Mortimore et al, 1988).
Mathematics and language tests were administered in three consecutive years to more
than 1000 students from 50 primary schools, which were randomly selected from primary
schools maintained by the Inner London Education Authority. The data are provided in the
location C:\LISREL 8.8 Student Examples\WORKSHOP as the SPSS data file
JSP2.SAV. The first portion of this file is shown in the following SPSS data window.
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jsp2.zav - SPSS Data Editor =10 =]
Eile Edit “iew Data Transform Analyze Graphs  Utilites  indow  Help
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school gender math mathz math3 en!il
1 1 0 23.000 24.000 23.000 7
2 1 1 14.000 11.000 -9.000 '
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5 1 0 22.000 23.000 -9.000 b
B 1 0 15.000 23.000 11.000 g
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Creating the PSF

Use the Import Data option from the File menu of the main window of LISREL 8.80 for
Windows to load the Open dialog box.

Select SPSS for Windows (*.sav) from the Files of type dropdown list box.

Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.

Select the file JSP2.SAV by clicking on it.

Click on the Open button to load the Save As dialog box.

Enter the name JSP2 in the File name string field.

Click on the Save button to open the following PSF window.

VVVVVY 'V
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B spP2 PsF
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SCHOOL | GENDER MATH1 MATHZ MATH3 | ENG1 | ENG?Z

1 0.000 23.000 24.000 23.000 J2.000
2 1.000 1.000 14.000 11.000 -9.000 7.000
3 1.000 1.000 36.000 32.000 39.000 88.000
4 1.000 1.000 24.000 26.000 Je.00n 12.000
b 1.000 0.000 2e.000 £3.000 -9.000 B7.000
b 1.000 0.000 19.000 23.000 11.000 52.000
I 1.000 1.000 22.000 22.000 26.000 37.000
i 1.000 0.000 18.000 29.000 28.000 R7.000
9 1.000 1.000 30.000 31.000 -4.000 42.000
10 1.000 0.000 29.000 29.000 -9.000 46.000
11 1.000 0.000 31.000 28.000 32.000 k9.000
12 1.000 0.0oa0 18.000 26.000 -4.000 k4.000
13 1.000 0.000 £3.000 -9.000 27.000 B3.000
14 1.000 0.000 39.000 35.000 36.000 §3.000
15 1.000 0.000 24.000 30.000 33.000 37.000
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Note that the —9.000 entries refer to missing values.

Prepare the PSF for Data Processing
Select the Define Variables option on the Data menu to load the Define Variables

VVVVVVVVY 'V

4.

dialog box.

Select the labels MATH1, MATH2, MATHS3, ENG1, ENG2, and ENG3.

Click on the Variable Type button to load the Variable Types for ... dialog box.
Activate the Continuous radio button.

Click on the OK button on the Variable Types for ... dialog box.

Click on the Missing Values button to load the Missing Values for ... dialog box.

Enter the value —9.000 in the first Global missing values string field.
Click on the OK button of the Missing Values for ... dialog box.

Click on the OK button on the Define Variables dialog box.

Select the Save option on the File menu to save the changes to the PSF.

Descriptive graphics

A Histogram for MATH1

VV VVVVVYVY

Use the Open option on the File menu to load the Open dialog box.

Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
Select the file JSP2.PSF by clicking on it.

Click on the Open button to open the PSF window for JSP2.PSF.

Select the Univariate option on the Graphs menu of the PSF window to load the

Univariate Plots dialog box.
Select the variable MATHL1.
Check the Normal curve overlay checkbox.
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» Click on the Plot button of the Univariate Plots dialog box to produce following plot
window.
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A Scatter Plot for MATH3 and ENG3

Close the plot window above.

Select the Bivariate option on the Graphs menu of the PSF window to load the
Bivariate Plots dialog box.

Select the variable MATH3 by clicking on it.

Click on the Select button in the Y-Variable section.

Select the variable ENG3 by clicking on it.

Click on the Select button in the X-Variable section.

Check the Scatter Plot checkbox.

Click on the Plot button to produce following plot window.

VVVVVY VYV
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Data screening

Use the Open option on the File menu to load the Open dialog box.

Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.

Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.

Select the file JSP2.PSF by clicking on it.

Click on the Open button to open the PSF window for JSP2.PSF.

Select the Data Screening option on the Statistics menu of the PSF window to open
the following text editor window for JSP2.OUT.
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Nunber of Missing Values per Variable

SCHOOL GENDER MATHI1 MATHZ MATHZ ENG1 ENG2 ENG3

Distribution of Missing Values

Total Sawmple Size = 1192
Number of Missing Values u] 1 2 3 4
Nurkber of Cases 837 o 270 o 35 7
&0 »
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Multiple linear regression analysis

Use the Open option on the File menu to load the Open dialog box.

Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
Select the file JSP2.PSF by clicking on it.

Click on the Open button to open the PSF window for JSP2.PSF.

Select the Regressions option on the Statistics menu of the PSF window to load the
Regression dialog box.

Select the variable MATH3 by clicking on it.

Click on the Select button in the Y-Variables section.

Select the variable ENG3 by clicking on it.

Click on the Select button in the X-Variables section.

Click on the Run button to produce following text editor window for JSP2.0OUT.

B¥ Jsp2.0uT Eg|
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Estimated Equations

MATH3 = 22 .083 + 0_193*ENG3 + Error, R? = 0.420
Standerr (0.376) (0.00780)
Z-values 58.753 25.325
P-values 0.000 0.000

Error Variance = 25.766

Logistic regression analysis

Use the Open option on the File menu to load the Open dialog box.

Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.
Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
Select the file USA.PSF by clicking on it.

Click on the Open button to open the PSF window for USA.PSF.

Select the Logistic Regressions option on the Statistics menu of the PSF window to
load the Logistic Regression dialog box.

Select the variable NOSAY by clicking on it.

Click on the Add button in the Ordinal Variables section.

Select the variables GENDER and EDUCAT.

Click on the Add button in the Covariates section.

Click on the Run button to produce following text editor window for USA.OUT.

VVYVYYVY VVVVVYVY| N
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B¥ usa.0UT

Tnivariate Logit Regression for NOS AT
Standard Paraweterization

Thresholds: -1.132 0.5a85 3.572

NOZAY = 0.00902 *GENDER + O0.576*EDUCAT + Error, R = 0.131

Standerr (0.118) (0.0893)
Z—ralues o.07%61 6,442
P—wralues o.939 0.oao
b
< >
8. Exploratory factor analysis (EFA)

Continuous variables

VV VYV VVVVVY

Use the Open option on the File menu to load the Open dialog box.

Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.

Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.

Select the file JSP2.PSF by clicking on it.

Click on the Open button to open the PSF window for JSP2.PSF.

Select the Classical Factor Analysis option on the Statistics menu of the PSF window
to load the Classical Factor Analysis dialog box.

Select the variable labels MATH1, MATH2, MATH3, ENG1, ENG2, and ENG3 from the
Variable List box.

Enter 2 in the Number of factors string field.

Click on the Select button to produce the following Classical Factor Analysis dialog
box.
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Classical Factor Analysis [Z|

“ariahle List: Select a subset of
Yariables (Optional):

rAATHT
MATHZ
MATH3
EMGI
EMG2
Select>» EMNG3

[(Ea> |
]

o ML Factor Analysis
I MINRES Factar Analysis
[ Principal Component Anahysis

Oifiens OEtiens | Mumber of Factors: |2
S (Dptional:)
| Factor Scaores

Cancel Swntax | Run

To select more than one wariahle at a time,hold down the CTRL
ken while clicking on the wariahles to be selected

» Click on the Run button to produce the following text editor window for JSP2.0OUT.

B¥ Jsp2.0UT M=E3
o

FPromax-Fotated Factor Loadings
Factor 1 Factor Z Unigque Var
MATHI 0.6835 0.263 0.290
MALTH= o.367 o.o30 o.210
MATHS 0.786 o.074 0.294
ENiz1 o.o37 0.3589 0.161
ENGZ 0.1z21 0.756 0.231
ENG3 0.2z249 0.678 0.273 w
< >

Ordinal variables

» Use the Open option on the File menu to load the Open dialog box.

> Browse for the location C:\LISREL 8.8 Student Examples\WORKSHOP.

» Select the PRELIS Data (*.psf) option from the Files of type dropdown list box.
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Select the file USA.PSF by clicking on it.

Click on the Open button to open the PSF window for USA.PSF.

Select the Ordinal Factor Analysis option on the Statistics menu of the PSF window
to load the Ordinal Factor Analysis dialog box.

Select the variable labels NOSAY, VOTING, COMPLEX, NOCARE, TOUCH, and
INTEREST from the Variable List box.

Enter 2 in the Number of factors string field.

Click on the Select button to produce the following Ordinal Factor Analysis dialog box.

YV YV VVV

Ordinal Factor Analysis

Yariakle List: Select a subset of
, Yariahles (Optional):
MNOSAY
WOTING
COMPLEX
MNOCARE
3 TOUCH
LEFTRIGH
EDUCAT
AGE 4
[tern response function
e Mormal " Logistic
Output Options | MNumber of Factors: |2
(Dptional:)
Cancel Synta | Fun |
To select more than one varable at atime.hold down the CTRL
key while clicking on the wariables to be selected

» Click on the Run button to produce the following text editor window for JSP2.0UT.
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w usa.ouT

Promax-Rotated Factor Loadings
Factor 1 Factor 2 Unique Var
NOSAY 0.715 0.027 0.465
VOTING 0.451 -0.056 0.824
COMPLEX 0.456 0.069 0.750
NOCARE 0.530 0.426 0.266
TOUCH 0.066 0.801 0.291
INTEREST 0.224 0.670 0.320
Factor Correlations
Factor 1 Factor 2 =
Factor 1 1.000
Factor 2 0.601 1.000 v
<0 i >

Using SIMPLIS syntax files

VVVY

Use the Open option on the File menu to load the Open dialog box.

Browse for the location C:\LISREL 8.8 Student Examples\SPLEX.

Select the file EX9A.SPL by clicking on it.

Click on the Open button to open the following text editor window for EX9A.SPL.

Fanel Model for Political Efficacy =

=101 %]

see Aish and Joreskog, Quality and Quantity (1980}
Observed YWariables from File PAMEL.LABE
Correlation Matrix from File PAMELUSA.PME
Asymptotic Cowarijance Matrix from File PANMELUSA ACP
sample size: 410
Latent Variables: Efficacl Respons! Efficac2 Respons2
Relationships:

MOSAYT - MOCARET = Efficact

MOCARET - INTERES1T = Responst

MOSAYZ2 - MOCAREZ = Efficac?

MOCAREZ - INTERESZ = Respons?Z

Efficac2 = Efficac!

Respons2 = Respons
Let the Errors for Efficac? and Respons2 correlate
Method of Estimation: Weighted Least Sguares
Fath Diagram
End of Prohlen|

xl

S
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Lines 1-2 specify a title for the analysis.

Line 3 specifies source for the labels for the observed variables.

Line 4 specifies the source for the polychoric correlation matrix.

Line 5 specifies the source for the estimated asymptotic covariance matrix of the polychoric
correlations.

Line 6 specifies that the data consist of 410 observations.

Line 7 specifies the labels for the 4 latent variables.

Lines 8-15 specify the model to be fitted to the data.

Line 16 specifies that the Weighted Least Squares (WLS) method for polychoric
correlations should be used to fit the model to the data.

Line 17 requests a path diagram with the results.

Line 18 specifies that no more SIMPLIS commands be processed.

» Click on the Run LISREL icon on the main toolbar to produce the following PTH window
for EX9A.PTH.

(=l B
0.21= HOSAYI \ HOSAY2 il
0.83 0.78
0. 53+ VOTING 0 a @ 0 7e— " VOTIHGZ |
0. 73
057 0.5l
0. 55+ COMFLEXE] 0 3 o ag COMPLEXZ
0. 25 HOCARE!L 40.48 - 0.66 0.405 HOCAREZ |
0.8l “:D.B'I-‘
o sa| TOUCH |4 0,51 0.87 TOUCHZ
0.17+= THTERES1 \ INTERES2 |
Chi-Sguare=113.83, df=48, P-walue=0.00000, PMIEA=O0.058 =
Kl | M
L | L] TwoaT T L | AT ST L' | L AT |.||||'|'|

10. The PTH window for EX9A.PTH

Structural Model
» Select the Structural Model option from the Model dropdown list box to produce the
following PTH window.
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Chi-Sguare=113.83, df=48, P-walue=0.00000, PRMIEA=O0.058
1] | v 4

Conceptual Path Diagram

» Select the Basic Model option from the Model dropdown list box.

» Select the Conceptual Diagram option from the Estimates dropdown list box to
produce the following PTH window.

=10 x|

=

= NOSAT1 HOSAY2 |=- J
—=| VOTING1 @ . VOTING2 |[==
—=| COMPLEX1 COMPLEX2 =
—=| HOCARE1 - HOCAREZ [=+
—=| TOTCHI TOUCHZ |==
—= JHTERES1 INTERESZ2 [-==—

d | [
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T-Values

» Select the Basic Model option from the Model dropdown list box.

» Select the T-values option from the Estimates dropdown list box to produce the
following PTH window.

=10l x|

NOSAYZ |=a

2. 7w HOSAYI

/

2

19.97
&. 01 VOTING] |e—_
1209 @ 12 aa
16,28
7. 39+ COMFLEX]

£

e
3.7
£.z4™= HNOCARE] 44.5—13.35 Rezponsz T.SS HNOCAREZ [==
Z1_8E

4. z7+= TOUCHIL fzmn le.53 TOUCHZ |==

VOTING2 |=a

{3

12_E1
QEEE&P.ZD

4.11

COMPLEZ [-=a

b

/.

z_ 17+ INTEREIl INTERES: |=a

Chi-3quare=113.83, df=48, P-wvalue=0.00000, BM3EA=0.038 -
KX | v 4
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11. Using LISREL syntax files

» Use the Open option on the File menu to load the Open dialog box.

> Browse for the location C:\LISREL 8.8 Student Examples\LS8EX.

» Select the file EX1. LS8 by clicking on it.

» Click on the Open button to open the following text editor window for EX1.LS8.

- OX

HYPOTHETICAL MODEL ESTIMATED BY ML

DA NI=11 NO=100

CM SY FI=EX1.COV

MO NY=4 NX=7 NE=2 NK=3 BE=FU PS=5Y,FR
EREY 20 1Y 452 162 4 1.X.3 4 X 32 IX 52 1309 3:.BE 2 1 BE 1 2
FI GA 1 3 GA 2 2

VAT 13 B3 2% 4 1 B 42 16 3

OU MI RS EF MR 55 5C

| £

Line 1 specifies a title for the analysis.

Line 2 specifies the number of observations (NO=100) and the number of observed

variables of the model (NI=10).

Line 3 specifies the source for the sample covariance matrix of the observed variables of

the model.

Lines 4-7 specify the model to be fitted to the sample covariance matrix specified in line 3.

Line 8 requests a path diagram with the results.

Line 9 specifies the additional results to be written to the output file.

» Click on the Run LISREL icon on the main toolbar to produce the following PTH window
for EX9A.PTH.

o [m] B
0,31+ NOSATI \ HOS4T2 I
o.22 o.7se J
0.53=l VOTINGL |m— @ o o] VOTINGZ |
o.78
a.67 0.5l
- EEEEi, B .
0. 55| COMPLEX1 o S e COMPLEXZ
0. 33| NOCAREL "{D.r;s . D.ssin.w; NOCARE? |
0.8l o.sv
o34 TOUCHD #7051 0.a7 TOUCHS
0. 17+ INTERES1 \‘ INTERESZ |
Chi-Sgquare=113.83, df=483, P-value=0.00000, FM3EA=0.058 o
4] | v
L] T Toe T T T P 8 I B e W - e | B R |}
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