STATISTICAL METHODS FOR ORDINAL DATA

1. Introduction

In practice, many multivariate data sets consist of observations of ordinal variables rather
than continuous variables. Most statistical methods for structural equation modeling
assume that the data are observations of continuous variables. In practice, this problem is
overcome by treating the ordinal variables as if they were continuous variables.
Unfortunately, this approach may yield misleading results (see e.g. Joreskog 1994 and
Joreskog & S6rbom 1999).

LISREL 8.7 for Windows (Joreskog & Soérbom 2004) includes several statistical methods
for the analysis of ordinal data. These methods are logistic regression, PROBIT regression
as well as Weighted Least Squares (WLS) and Diagonally Weighted Least Squares
(DWLS) for polychoric correlation and covariance matrices. More details about these
methods are provided in Jéreskog (2002).

In this note, the logistic and PROBIT regression methods of LISREL 8.7 for Windows are
illustrated by using a data set of observations on ordinal variables. This data set is
described in the next section. The method of logistic regression is illustrated in Section 3.
Thereafter, the PROBIT regression method is illustrated. Multivariate logistic and PROBIT
regression analyses are performed in Section 5. In Section 6, the methods of multivariate
logistic and PROBIT regression are demonstrated.



2. The Data

Barnes & Kaase (1979) conducted a cross-national survey to obtain information on
conventional and unconventional forms of political participation in industrial societies. This
survey is known as the Political Action Survey. This survey included several attitude and
perception statements to which the respondents had to respond to as one of agree
strongly, agree, disagree, disagree strongly, don’t know or no answer. Amongst others, the
following six statements were administered to each respondent.

“People like me have no say in what the government does.” (NOSAY)

“Voting is the only way that people like me can have any say about how the government
runs things.” (VOTING)

“Sometimes politics and government seem so complicated that a person like me cannot
really understand what is going on.” (COMPLEX)

“I don’t think that public officials care much about what people like me think.” (NOCARE)

“Generally speaking, those we elect to Congress in Washington lose touch with people
pretty quickly.” (TOUCH)

“Parties are only interested in people’s votes but not in their opinions. (INTEREST)

The responses to these statements of a sample of 1076 United States respondents, along
with their gender (GENDER), education level (EDUCAT), age (AGE) and left-right score
(LEFTRIGH), are listed in the PRELIS System File (PSF) USA.PSF. This file is located in
the WORKSHOP folder of the LISREL 8.7 for Windows installation folder. A small portion
of this file is shown in the following PSF window.

=101 %
NOSAY | VOTING | coMPLEX| NOCARE | ToucH [INTEREST| GENDE

1 2.000 1.000 1.000 1.000 1.000 2,4l

2 2.000 3.000 3.000 3.000 2.000 3.000 2]
3 3.000 2.000 2.000 3.000 3.000 3.000 1,
4 2.000 2.000 2.000 2.000 1.000 2.000 2
5 2.000 1.000 2.000 2.000 1.000 1.000 1,
6 3.000 3.000 2.000 2.000 3.000 3.000 1,
7 2.000 2.000 3.000 1.000 1.000 1.000 1,
8 3.000 2.000 3.000 3.000 2.000 3.000 1,
9 3.000 2.000 1.000 1.000 2.000 2.000 2
10 1.000 1.000 1.000 1.000 1.000 1.000 2
11 3.000 3.000 3.000 3.000 3.000 3.000 2.
12 1.000 4000 4000 2.000 1.000 1.000 2
13 3.000 3.000 2.000 2.000 2.000 2.000 1,
14 3.000 3.000 4.000 2.000 1.000 1.000 1,

15 3.000 3.000 3.000 3.000 3.000 3.000 2
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Logistic Regression of NOSAY

Use the Open option on the File menu to load the Open dialog box.

Select the PRELIS data (*.psf) option from the Files of type: dropdown list box.
Browse for the file USA.PSF in the WORKSHOP folder of LISREL 8.7 for Windows.
Click on the Open push button to open USA.PSF in a PSF window.

Click on the Logistic Regressions option on the Statistics menu to load the Logistic
Regression dialog box.

Select the label NOSAY in the Variables list box.

Click on the Add push button to transfer the label NOSAY to the Ordinal Variables list
box.

Select the labels GENDER, LEFTRIGH, EDUCAT and AGE in the Variables list box.
Click on the Add push button to produce the following Logistic Regression dialog box.

Logizstic Regression x|

Warnables: Ordinal Yanables:

NOSAY NOSAY
wOTING

COMPLEX add o2
NOCARE

TaucH £+ Bemove
INTEREST
GENDER
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LEFTRIGH LCovariates;
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[ Alternative Parametenization

Suntax Fun Cancel

To zelect maore thak one wariable at a time hold down the
CTRL key while clicking on the wariables to be zelected

Click on the Run push button to produce the following text editor window for USA.OUT.
101 x|
Univariate Logit Regression for MOSAY
standard Parameterization
Thresholds: -2.348 -0.633 2.403
MOSAY = - 0.00433*GEMDER + 0. 0844*LEFTRIGH + 0. 650*EDUCAT + 0.00732*AGE
(0.113) (0.0323) (0.0922) (0.00364)
-0.0411 2.616 7.043 2147
+ Error, RE = 0.171
¢I )




PROBIT Regression of NOSAY

Select the Close all option on the Window menu to close all open windows.

Use the Open option on the File menu to load the Open dialog box.

Select the PRELIS data (*.psf) option from the Files of type: dropdown list box.
Browse for the file USA.PSF in the WORKSHOP folder of LISREL 8.7 for Windows.
Click on the Open push button to open USA.PSF in a PSF window.

Click on the Probit Regressions option on the Statistics menu to load the Probit
Regressions dialog box.

Select the label NOSAY in the Variables list box.

Click on the Add push button to transfer the label NOSAY to the Ordinal Variables list
box.

Select the labels GENDER, LEFTRIGH, EDUCAT and AGE in the Variables list box.
Click on the Add push button to produce the following Probit Regressions dialog box.

Probit Regressions x|
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YOTIMNG
COMPLEX G
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o | e |
I IMTEREST
L GEMHDER
i LEFTRIGH P
3 EDLCAT Covaniates:
| b GEMDER
: ] |LEFTRIGH
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[ alternative Parametenization

Dutput Optionz... | Fix Threzholds. .. |

Marginal Threzshalds... |

Suntax | Bun Cancel |

» Click on the Run push button to produce the following text editor window for USA.OUT.



=131 x|

Total Sample Size = 1076

Uniwariate Probit Regression for MOSAY
Standard Parameterization

Thresholds:  -1.361 -0.391 1.379
NOSAY = D.00899"GENDER + 0.0424*LEFTRIGH + 0.360°EDUCAT + 0. 00453*AGE |
(0.0675) (0.0184) (0.0519) (0.00207)
0.133 2.308 6.946 2167

+ Error, R® = 0.05B86

5. Stepwise Logistic and PROBIT Regression of NOSAY
Stepwise Logistic Regression

» Select the Close all option on the Window menu to close all open windows.

» Use the Open option on the File menu to load the Open dialog box.

> Browse for the file SLOGIT.PR2 in the WORKSHOP folder of LISREL 8.7 for Windows.
» Click on the Open push button to open the following text editor window.

B SLOGIT_PR2

=10l x|

Logit Regression of MOSAY =
S¥=USA . PSF
LR MOSAY on EDUCAT
LR MOSZAY on EDUCAT LEFTRIGH
LR MOZAY on EDUCAT LEFTRIGH AGE
LR MOZAY on EDUCAT LEFTRIGH AGE GEMDER
oy —

-
53

| Ly

Line 1 specifies a title for the analysis.

Line 2 specifies the raw data source.

Lines 3 to 6 specify the stepwise logistic regression analysis of NOSAY.
Line 7 specifies that the standard PRELIS results should be produced.

» Click on the Run PRELIS icon on the main toolbar to produce the text editor window for
SLOGIT.OUT.

Use the Open option on the File menu to load the Open dialog box.

Select the Output (*.out; *.fit) option from the Files of type: dropdown list box.
Browse for the file SLOGIT.FIT in the WORKSHOP folder of LISREL 8.7 for Windows.
Click on the Open push button to open the following text editor window.
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B sLoGIT AT ' - O] x|

Variahle -21nL  Chi-square df Covariates o
MOSAY 23566 408 42 6845 1 EDUCAT
MOSAY 2345 402 2. 701 2 EDUCAT LEFTRIGH
MOSAY 2340. 782 A7 312 3 EDUCAT LEFTRIGH AGE
MOSAY 2340. 780 A7 313 4 EDUCAT LEFTRIGH AGE GENDER
b4 -
ol 24

Stepwise PROBIT Regression

» Select the Close all option on the Window menu to close all open windows.

» Use the Open option on the File menu to load the Open dialog box.

> Browse for the file SPROBIT.PR2 in the WORKSHOP folder of LISREL 8.7 for
Windows.

» Click on the Open push button to open the following text editor window.

_lojx]
Probit Regression of MOSAY =
=Y =USA . PSR

PR NOZAY on EDUCAT

PR NOZAY on EDUCAT LEFTRIGH

PR NOZAY on EDUCAT LEFTRIGH AGE

PR NOSAY on EDUCAT LEFTRIGH AGE GEMDER
ad

H

J | oy

Line 1 specifies a title for the analysis.

Line 2 specifies the raw data source.

Lines 3 to 6 specify the stepwise PROBIT regression analysis of NOSAY.
Line 7 specifies that the standard PRELIS results should be produced.

» Click on the Run PRELIS icon on the main toolbar to produce the text editor window for
SPROBIT.OUT.

Use the Open option on the File menu to load the Open dialog box.

Select the Output (*.out; *.fit) option from the Files of type: dropdown list box.

Browse for the file SPROBIT.FIT in the WORKSHOP folder of LISREL 8.7 for Windows.
Click on the Open push button to open the following text editor window.
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B sPROBIT FIT -0 x|
Wariahle -21nL  Chi-sgquare  df Cowariates =
MOSAY 2357 . 965 40. 136 1 EDUCAT
MOSAY 2343 465 48. 635 2 EDUCAT LEFTRIGH
MOSAY 2344 . 603 53. 494 3 EDUCAT LEFTRIGH AGE
MOSAY 2344 . 531 53.512 4 EDUCAT LEFTRIGH AGE GEMDER —
{1 2

6. Multivariate Logistic and PROBIT Regression
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Multivariate Logistic Regression

Select the Close all option on the Window menu to close all open windows.

Use the Open option on the File menu to load the Open dialog box.

Select the PRELIS data (*.psf) option from the Files of type: dropdown list box.
Browse for the file USA.PSF in the WORKSHOP folder of LISREL 8.7 for Windows.
Click on the Open push button to open USA.PSF in a PSF window.

Click on the Logistic Regressions option on the Statistics menu to load the Logistic
Regression dialog box.

Select the labels NOSAY, VOTING, COMPLEX, NOCARE, TOUCH and INTEREST in
the Variables list box.

Click on the Add push button to transfer the labels NOSAY, VOTING, COMPLEX,
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WOTING
COMPLEX
MOCARE
TOUCH
INTEREST

i

4 |

W ariables:

NOSAY
VOTING
COMPLEX
NOCARE
TOUCH
INTEREST
GENDER
LEFTRIGH
B EDucaT
i GE

Syntax |

Logistic Regression '

Add > |

<% Bemave

i

<% Bemave |

[ Altemnative Parameterization

Fun |

x|
Ordinal ' ariables:

MOS&Y
VOTING
COMPLE=
MOCARE
TaucH
INTEREST

LCovarniates:

GENDER

LEFTRIGH i
EDLCAT y
AGE

Cancel

To zelect more than one wariable at a time hold dovn the
CTRL ke while clicking on the wariables to be zelected

NOCARE, TOUCH and INTEREST to the Ordinal Variables list box.
Select the labels GENDER, LEFTRIGH, EDUCAT and AGE in the Variables list box.
Click on the Add push button to produce the following Logistic Regression dialog box.

Click on the Run push button to produce the text editor window for USA.OUT.

Use the Open option on the File menu to load the Open dialog box.

Select the Output (*.out; *.fit) option from the Files of type: dropdown list box.
Browse for the file USA.FIT in the WORKSHOP folder of LISREL 8.7 for Windows.

=101 %

GEMDER LEFTRIGH
GEMDER LEFTRIGH
GEMDER LEFTRIGH
GEMDER LEFTRIGH
GEMDER LEFTRIGH
GEMDER LEFTRIGH

.

EDUCAT AGE
EDUCAT AGE
EDUCAT AGE
EDUCAT AGE
EDUCAT AGE
EDUCAT AGE —

o

Multivariate PROBIT Regression

> Select the Close all option on the Window menu to close all open windows.
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Use the Open option on the File menu to load the Open dialog box.

Select the PRELIS data (*.psf) option from the Files of type: dropdown list box.
Browse for the file USA.PSF in the WORKSHOP folder of LISREL 8.7 for Windows.
Click on the Open push button to open USA.PSF in a PSF window.

Click on the Probit Regressions option on the Statistics menu to load the Probit

Regressions dialog box.

Select the labels NOSAY, VOTING, COMPLEX, NOCARE, TOUCH and INTEREST in

the Variables list box.

Click on the Add push button to transfer the labels NOSAY, VOTING, COMPLEX,
NOCARE, TOUCH and INTEREST to the Ordinal Variables list box.

Select the labels GENDER, LEFTRIGH, EDUCAT and AGE in the Variables list box.
Click on the Add push button to produce the following Probit Regressions dialog box.

N Probit Regreszions

X

Yariable Lizt Ordinal W ariables:
MOSAY M
O YOTING YOTING
t |COMPLEX addy | VBTG
¢ IMOCARE NOCARE
TOUCH <+ Hemove | TOUCH
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g A [EDUCAT
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<< Bemove |

[ Altemnative Parameterization

Output Ophiokz. .. | Eir Threshaldz... |
Marginal Threzholds. .. |
Suntax | Bun Cancel |

Click on the Run push button to produce the text editor window for USA.OUT.

Use the Open option on the File menu to load the Open dialog box.

Select the Output (*.out; *.fit) option from the Files of type: dropdown list box.
Browse for the file USA.FIT in the WORKSHOP folder of LISREL 8.7 for Windows.
Click on the Open push button to open the following text editor window.



=10l x|

Wariahle -21nL Chi-sguare df Cowvariates =l
MOSAY 2344 . 591 53.512 4 GEWDER LEFTRIGH EDUCAT AGE
WOTING 2470. 643 106. 818 4  GEWDER LEFTRIGH EDUCAT AGE
COMPLEX 2284 . 678 108. 725 4  GEWDER LEFTRIGH EDUCAT AGE
MOCARE 2401.907 53. 767 4 GEWDER LEFTRIGH EDUCAT AGE
TOUCH 2248 114 35,305 4  GEWDER LEFTRIGH EDUCAT AGE
INTEREST 2338, 651 26, 163 4 GENDER LEFTRIGH EDUCAT AGE
ol | 1L
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