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Introduction 

To illustrate the use of the interface in creating syntax files, the data file exampl01.dat in the 
examples subfolder of the BILOG-MG installation folder is used. This problem is based on an 
example in Thissen, Steinberg & Wainer (1993).  

In the late 1980s, R. Darrell Bock created a “College Level Spelling Test” comprising a sample 
of 100 words drawn from a large source list by simple random sampling. Data collected using 
that test are the basis for the empirical example in the paper “IRT Estimation of Domain Scores” 
(R.D. Bock, M.F. Zimowski, & D. Thissen, Journal of Educational Measurement, 1997, 34, 197-
211). Parameter estimates for the 2PL IRT model for the 100-item test are tabulated in that 
paper. Bock created the script for conventional oral presentation of the test, and recorded the 
original reading of the script (by Monica Marie Bock) on reel-to-reel magnetic tape. Subsequent 
copies onto cassette tape were used by Jo Ann Mooney in the collection of data from around 
1000 University of Kansas Undergraduates. We are using the file with 100 words (items) and 
1000 records (examinees). 

The words for the test were randomly selected from a popular wordbook for secretaries. Students 
were asked to write the words as used in a sentence on the tape recording. Responses were 
scored 1 if spelled correctly and 0 if spelled incorrectly. Because the items are scored 1,0, 
according to the defaults assumed by the program, an answer key is not required.  



The purpose of this section is to give the new user a quick overview of the interface and the 
absolute minimum input needed to run the program. A few lines of the data in exampl01.dat are 
shown below: 

 11 0000 
 21 0001 
 31 1000 
 41 1001 
… 
162 1111 

The first three characters in each line represent the examinee identification field. This is followed 
by the responses to the four items in the test. 

A first model: 2PL model for spelling data 

As a first example, we wish to set up a simple 2-PL model for this data. To construct a command 
file, begin by selecting the New option from the File menu. The Open dialog box is now 
activated. 

 

Assign a name, with the *.blm file extension, to the command file. In this case, the command file 
first.blm is created in the examples folder as shown below. Click Open when done to return to 
the main BILOG-MG window. 



 

Note that a number of options have been added to the main menu bar of the BILOG-MG window. 
Of interest for this example are the Setup, Data, Run and Output options. The Setup menu is 
used to describe the model to be fitted to the data. As a first step, select the General option from 
this menu to access the General dialog box. 

 

The General dialog box has four tabs, on which both required and optional keywords may be 
set. On the Job Description tab below, the number of items in the test is indicated as 4. The type 
of model is selected on the Model tab. As the default model fitted by BILOG-MG is a 2PL model, 
this tab is not used now. Click OK to return to the main window. 



 

The next step in specifying the analysis is to assign the items to be calibrated to the test. To do 
this, select the Item Analysis option on the Setup menu to access the Item Analysis dialog box.  

Change the default value of 1 under Subtest Length to 4 by clicking in this field and typing in 
“4”. By default, all items will be analyzed, as indicated under the Analyze this run header. Click 
OK when done. 

This completes the model specification. All that remains to be done is to provide information on 
the data. To do so, the Data menu is used. In this case, we have examinee data and thus the 
Examinee Data option is selected from the Data menu.   



 

On the Examinee Data dialog box, enter the number of characters representing the examinee 
identification (in this case 3) in the Number of Case ID Characters field. By default, all data 
are used as shown below.  

To provide information on the name and format of the data file, click the Data File tab.  

 Use the Browse button to browse for the data file.  
 Next, indicate that the data are in fixed format by clicking the Read as Fixed-Column 

Records radio button. 
 Complete the table in the Read as Fixed-Column Records group box by clicking in the 

cell next to Case ID under the First header. Enter a “1” here to indicate that the examinee 
identification starts in column 1 of the data. Next, enter a “3” under the Last header to 
indicate the end of the examinee identification. 

 Note that Form Number, Group Number, etc. is disabled due to the information we 
entered from the Setup menu. The only other fields to complete are the Response String 
fields. 

 The response to the first item is in column 5 of the data, so a “5” is entered in the cell next 
to Response String under the First header. The response to the last item is in column 8, 
and an “8” is thus entered in the Last column. 

 By default, BILOG-MG assumes that there is one line of data for each examinee, as 
indicated by the Number of Data Record per Case field. As this is the case for data in 



exampl01.dat, no further information is required. Click the Set Format button to write 
the format statement (3A1,1X,4A1) to the Format String field. Click OK to return to the 
main BILOG-MG window. 

 



 

Having completed the specification in terms of model and data, the command file is created by 
selecting the Build Syntax option from the Run menu. The syntax created by the program is 
now displayed in the main window, as shown below. Note that no options are given on the 
ITEMS and SCORE commands in this file, indicating that all program defaults will be used.  

Save the completed syntax to file by selecting the Save option on the File menu. 



 

The analysis is now performed by using some of the other options on the Run menu. Although 
the analysis can be done phase by phase (using the Classical Statistics Only, Calibration Only, 
and Scoring Only options) all three phases can be run in sequence by selecting the Stats, 
Calibration and Scoring option from this menu. 

 

After successful completion of all three phases of the analysis, a message to this effect is 
displayed on the screen. If a problem was encountered during analysis, this message box will 
indicate that all phases were not completed successfully. Access the output from the analysis 
through the Output menu. Classical statistics are given in the *.ph1 file.  

 



A section of this output file is shown below. 

 

In the first.ph2 file, the results of the item calibrations are given. The item parameter estimates 
for the four items in the test are shown below. 

 

Scoring results are given in the first.ph3 file. The complete list of scores is printed to this file by 
default. A section of this output, showing summary statistics for the score estimates, is shown 
below. 



 

A second model: DIF model for spelling data 

The data analyzed in the previous example came from two groups of respondents. The groups in 
this example are the two sexes. The same four items are presented to both groups on a single test 
form. The group indicator is found in column 3 of the data records. 

 11 0000 
 21 0001 
 31 1000 
 41 1001 
… 
162 1111 

The third column of the data contains either a 1 or a 2, indicating whether an examinee belonged 
to group 1 (male) or group 2 (female). 

The previous single-group analysis for this group, contained in the command file first.blm, is 
modified to perform a DIF analysis for the two groups. As a first step, the General option on the 
Setup menu is used to indicate the presence of multiple groups. 

On the Job Description tab of the General dialog box, change the Number of Examinee 
Groups from the default value of 1 to 2, as shown below. 



 

In the case of a DIF model, a 1PL model is required. To change the model from the default 2PL 
model previously used, click the Model tab and check the 1-Parameter Logistic (1PL) radio 
button in the Response Model group box. 

To request a DIF model, click the Differential Item Functioning (DIF) radio button in the 
Special Models group box. By default, the first group will be used as reference group as 
indicated in the Reference Group field. 

Once this is done, all necessary changes to the General dialog box have been made. Click OK to 
return to the main BILOG-MG window. 



 

The allocation of items to be calibrated for each of the two groups is specified using the Item 
Analysis option of the Setup menu. Once this option is selected, the Item Analysis dialog box is 
displayed.  

Leaving the Subtests tab as previously completed, click the Group Items tab. By default, all 
items will be selected for the first group. This is indicated by the display of the item names in a 
bold font in the first column of the table. To select all four items for the second group, click on 
ITEM0001 in the second column. While holding the Shift button on the keyboard down, click on 
ITEM0004. All four items are now highlighted. Click the Select button at the bottom left of the 
dialog box to select all items.  

This completes the model specification. Click OK to return to the main window. 



 

The only remaining task is to revise the reading of the data file so that the group identification 
field can be recognized and processed by the program. To do so, select the Examinee Data 
option from the Data menu.  

On the General tab of the Examinee Data dialog box, the number of case identification 
characters is now decreased to 2, as shown below. (Recall that previously this field was set to 3: 
in effect, a combination of actual examinee ID and group ID was used to identify the cases in the 
previous example.) 



 

The format statement is now adjusted accordingly by changing the entries in the Read as Fixed-
Column Records group box: 

 The Last value for the Case ID is set to 2.  
 The Group Number field, now enabled due to our selection of a multiple-group analysis 

from the Setup menu, is set to 3 under both the First and Last headers, as the group 
identification, given in column 3 of the data, is one character in length. 

 Finally, these changes are made to the format statement by clicking the Set Format 
button. Note that the format statement now contains an additional “I1” indicating the 
group number in integer format. 

This completes the syntax specification. Return to the main window by clicking the OK button. 



 

The revised command file is generated by selecting the Build Syntax option from the Run 
menu. 

 

After generating the syntax, it is saved to file using the Save As option on the File menu. The 
revised syntax is saved in the file second.blm in the examples folder. Click the Save button after 
specifying a name for and path to the new command file. 



 

When the syntax displayed in the main BILOG-MG window is compared to the first example, we 
note the addition of two GROUP commands and the NGROUP and DIF keywords on the INPUT 
command. The revised format statement is also included. The NPARM keyword on the GLOBAL 
command (not shown here) indicates that a 1-PL model is requested. 

The three phases of the analysis can be run separately using the Classical Statistics Only, 
Calibration Only, and Scoring Only options on the Run menu. To run the phases sequentially, 
select the Stats, Calibration, and Scoring option from this menu.  

Output for the analysis is accessed as before using the Output menu from the main menu bar. 

 

In the partial output from the second.ph1 file for this DIF analysis classical item statistics are 
provided by group. Similar statistics are also given for the combined group (not shown below). 



 

The Phase 2 output in the second.ph2 file provides item parameter estimates, and DIF specific 
output as shown below. 

 



Although the second.ph3 file is created as shown below, no scoring is performed in the case of a 
DIF analysis. 
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